Due to inactivity, this wiki is a candidate for deletion. If you believe this wiki should remain, please post a message at the community portal, or message the Wiki Manager directly. Objections should be made before 19 January, 2020.

System requirements

From Rift Keeper Wiki
Jump to: navigation, search

This article is a stub. You can help Rift Keeper Wiki by expanding it.

The following are the minimum and recommended system requirements for Rift Keeper. While these requirements do not represent a guaranteed working configuration, meeting the minimum requirements should ensure at least a launch-able environment.

Recommended requirements[edit | edit source]

Minimum requirements[edit | edit source]

See also[edit | edit source]